CCNA LAB SVI DHCP server VTP Root guard BPDU filter Inter VLAN routing 802.1Q and RSTP
LAB Diagram
Configure the topology as per the diagram
Configure VLAN_10 VLAN_20 VLAN_30 on Core_SW
Configure 802.1Q Trunk Link Between Access Switches and Core_SW
Configure VTP version 2 on Core_SW
Configure VTP domain name lab.com
Make sure rest of the switches will get this information
Configure the ports into their VLAN as per the topology
Configure the IP address to VLANs for inter VLAN routing
IP 10.10.10.0/24 to VLAN 10
IP 20.20.20.0/24 to VLAN 20
IP 30.30.30.0/24 to VLAN 30
Configure DHCP server for VLAN 10,20,30 on Core_SW
CORE_SW#show interfaces trunk
Core_SW(config)#interface range Gi 0/0-3
Core_SW(config-if-range)#switchport trunk encapsulation dot1q
Core_SW(config-if-range)#switchport mode trunk
Core_SW(config-if-range)#switchport nonegotiate
Core_SW(config-if-range)#switchport trunk allowed vlan 10,20,30
Core_SW(config-if-range)#switchport trunk native vlan 999
Core_SW(config-if-range)#exit
FLOOR_1(config)#interface Gi 0/0
FLOOR_1(config-if)#switchport trunk encapsulation dot1q
FLOOR_1(config-if)#switchport mode trunk
FLOOR_1(config-if)#switchport nonegotiate
FLOOR_1(config-if)#switchport trunk allowed vlan 10,20,30
FLOOR_1(config-if)#switchport trunk native vlan 999
FLOOR_1(config-if)#exit
FLOOR_2(config)#interface Gi 0/0
FLOOR_2(config-if)#switchport trunk encapsulation dot1q
FLOOR_2(config-if)#switchport mode trunk
FLOOR_2(config-if)#switchport nonegotiate
FLOOR_2(config-if)#switchport trunk allowed vlan 10,20,30
FLOOR_2(config-if)#switchport trunk native vlan 999
FLOOR_2(config-if)#exit
FLOOR_3(config)#interface Gi 0/0
FLOOR_3(config-if)#switchport trunk encapsulation dot1q
FLOOR_3(config-if)#switchport mode trunk
FLOOR_3(config-if)#switchport nonegotiate
FLOOR_3(config-if)#switchport trunk allowed vlan 10,20,30
FLOOR_3(config-if)#switchport trunk native vlan 999
FLOOR_3(config-if)#exit
Core_SW(config)#VTP domain lab.com
Domain name already set to lab.comCore_SW(config)#VTP mode server
Core_SW(config)#VTP version 2
Core_SW(config)#end
FLOOR_1(config)#VTP domain lab.com
Domain name already set to lab.comFLOOR_1(config)#VTP mode client
FLOOR_1(config)#VTP version 2
FLOOR_1(config)#end
FLOOR_2(config)#VTP domain lab.com
Domain name already set to lab.com
FLOOR_2(config)#VTP mode client
FLOOR_2(config)#VTP version 2
FLOOR_2(config)#end
FLOOR_3(config)#VTP domain lab.com
Domain name already set to lab.com
FLOOR_3(config)#VTP mode client
FLOOR_3(config)#VTP version 2
FLOOR_3(config)#end
Core_SW(config)#vlan 10
Core_SW(config-vlan)#vlan 20
Core_SW(config-vlan)#vlan 30
Core_SW(config-vlan)#exit
FLOOR_1(config)#interface range gi 0/1-2
FLOOR_1(config-if-range)#switchport mode access
FLOOR_1(config-if-range)#switchport access vlan 10
FLOOR_1(config-if-range)#exit
FLOOR_1(config)#end
FLOOR_2(config)#interface range gi 0/1-2
FLOOR_2(config-if-range)#switchport mode access
FLOOR_2(config-if-range)#switchport access vlan 20
FLOOR_2(config-if-range)#exit
FLOOR_2(config)#end
FLOOR_3(config)#interface range gi 0/1-2
FLOOR_3(config-if-range)#switchport mode access
FLOOR_3(config-if-range)#switchport access vlan 30
FLOOR_3(config-if-range)#exit
FLOOR_3(config)#end
Core_SW(config)#interface vlan 10
Core_SW(config-if)#ip address 10.10.10.254 255.255.255.0
Core_SW(config-if)#no shutdown
Core_SW(config-if)#exit
Core_SW(config)#interface vlan 20
Core_SW(config-if)#ip address 20.20.20.254 255.255.255.0
Core_SW(config-if)#no shutdown
Core_SW(config-if)#exit
Core_SW(config)#interface vlan 30
Core_SW(config-if)#ip address 30.30.30.254 255.255.255.0
Core_SW(config-if)#no shutdown
Core_SW(config-if)#exit
Core_SW#show ip interface brief
Interface IP-Address OK? Method Status Protocol
Vlan10 10.10.10.254 YES manual up up
Vlan20 20.20.20.254 YES manual up up
Vlan30 30.30.30.254 YES manual up up**
Core_SW(config)#service dhcp
Core_SW(config)#ip dhcp pool VLAN10
Core_SW(dhcp-config)#network 10.10.10.0 255.255.255.0
Core_SW(dhcp-config)#default-router 10.10.10.254
Core_SW(dhcp-config)#dns-server 8.8.8.8
Core_SW(dhcp-config)#exit
Core_SW(config)#service dhcp
Core_SW(config)#ip dhcp pool VLAN20
Core_SW(dhcp-config)#network 20.20.20.0 255.255.255.0
Core_SW(dhcp-config)#default-router 20.20.20.254
Core_SW(dhcp-config)#dns-server 8.8.8.8
Core_SW(dhcp-config)#exit
Core_SW(config)#service dhcp Core_SW(config)#ip dhcp pool VLAN30 Core_SW(dhcp-config)#network 30.30.30.0 255.255.255.0 Core_SW(dhcp-config)#default-router 30.30.30.254 Core_SW(dhcp-config)#dns-server 8.8.8.8 Core_SW(dhcp-config)#exit
Core_SW(config)#spanning-tree vlan 10,20,30 root primary
Core_SW(config)#end
Core_SW(config)#interface range gi 0/1-3
Core_SW(config-if-range)#spanning-tree guard root
Core_SW(config-if-range)#end
\*Oct 2 17:26:10.692: %SPANTREE-2-ROOTGUARD_CONFIG_CHANGE: Root guard enabled on port GigabitEthernet0/1
Oct 2 17:26:10.693: %SPANTREE-2-ROOTGUARD_CONFIG_CHANGE: Root guard enabled on port GigabitEthernet 0/2
*Oct 2 17:26:10.693: %SPANTREE-2-ROOTGUARD_CONFIG_CHANGE: Root guard enabled on port GigabitEthernet 0/3.*
Subscribe to my newsletter
Read articles from ko thu directly inside your inbox. Subscribe to the newsletter, and don't miss out.
Written by