Networking project based on University campus


In this project the university has 2 campuses situated 10 miles apart from each other and staff is distributed in 4 faculities.
Requirements
main campus:
. Building A: administrative staff in the departments of management, HR and finance including the facility of business too in this building
. Building B: engeering and computing, art and design
. Building C: students lab and IT department. IT department also host the university web server and other servers
Smaller campus:
. Faculity of health and sciences
Each department is supposed to have its own ip network
Switches should be configured with related VLANs
RIPv2 routing protocol will be used to provide routing for routers in internal network and static routing for the external sever
ip address will be assigned by the router based DHCP sever
Project
I designed the topfology using the GNS3 software. To design this i followed the requirements. I have used the ethernet to establish a connection within a campus and to connect the different campus with the routers the serial cable is used.
Configuration
I started doing the configuration by enabling the ports used on the routers and switch using the no shutdown
command by entering into the configuration of the ports using:
config terminal
interface <interfaceName>
no shut
end
next we will check which interface on serial connection is DCE between routers as DCE interfaces provide the clock rate and the DTE has to be in sync with it. command to check if the interface is DCE or DTE is show controllers <interfaceName>
now i have configured the departments with thier own unique vlan using these commands:
Admin#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Admin(config)#inter range fa1/0 - 15
Admin(config-if-range)#switchport mode access
Admin(config-if-range)#switchport access vlan 10
Admin(config-if-range)#do wr
Building configuration...
[OK]
Admin(config-if-range)#end
done the same with every department to configure the VLANs on them
after assigning the vlan to every departments in access layer then i also need to assign the vlan to the interfaces connected to certain departements with thier vlan on a MainCampusSwitch. to assign the vlan 10 to interface f1/0 on maincampus switch i used the following commands:
mainCampusSwitch#conf t
Enter configuration commands, one per line. End with CNTL/Z.
mainCampusSwitch(config)#int fa1/0
mainCampusSwitch(config-if)#switchport mode access
mainCampusSwitch(config-if)#switchport access vlan 10
mainCampusSwitch(config-if)#do wr
Building configuration...
[OK]
mainCampusSwitch(config-if)#end
these commands is executed on other interfaces with thier required vlans
Enabling the trunk port
branch switch is connected to two different vlans with different interfaces configured to be in that vlan but to forward that data to branch router we can’t use the access ports as it won’t allow multiple vlans to pass through it. So to make a data transfer possible from multiple vlans i have configured between branch switch and branch router to Trunk port as trunk port moves data from any vlan
in this architecture the router will be known as a router on a stick as only one link is used to connect multiple vlans
configuration i did on branchswitch and maincampusswitch is:
conf t
interface fa1/2
switchport trunk encapsulation dot1q
switchport mode trunk
do wr
end
Assigning IP addresses
IP address is needed to talk with other vlans that is Inter-Vlan routing
to assign a ip address to a interface on mainRouter i used the following commands:
conf t
int se0/1
ip address 10.10.10.1 255.255.255.252
exit
int se0/2
ip address 10.10.10.5 255.255.255.252
exit
the same has been done with thier respective ip address which are:
branchrouter s0/0: 10.10.10.2/30
cloud s0/1: 10.10.10.6/30
cloud s0/2: 20.0.0.1/30
server e0: ip address 20.0.0.2 255.255.255.252 20.0.0.1
in this the last address is gateway route
Inter-Vlan routing
To initiate a inter-vlan routing I have to create a sub-interface on router on the other side of which is switch with trunk port sending all the vlans to router with just one link
so with the help of subinterface i assigned the ip address of one vlan to that one sub-interface. so if i have 2 vlans i have created a 2 sub-interface to enable inter-vlan routing
ip address used on this sub-interface will be used as a gateway for the related vlan
branchRouter#conf t
Enter configuration commands, one per line. End with CNTL/Z.
branchRouter(config)#int fa0/0.90
branchRouter(config-subif)#encapsulation dot1q 90
branchRouter(config-subif)#ip address 192.168.9.1 255.255.255.0
branchRouter(config-subif)#exit
DHCP
I have used routers as a DHCP server to provide the ip address to the devices with ip address assingned for thier vlans
I created a DHCP pool for the different departments
branchRouter(config)#service dhcp
branchRouter(config)#ip dhcp pool staff-pool
branchRouter(dhcp-config)#network 192.168.9.0 255.255.255.0
branchRouter(dhcp-config)#default-router 192.136.9.1
branchRouter(dhcp-config)#dns-server 192.168.9.1
branchRouter(dhcp-config)#do wr
branchRouter(dhcp-config)#exit
branchRouter(config)#ip dhcp pool studlb-pool
branchRouter(dhcp-config)#network 192.168.10.0 255.255.255.0
% A pool already exists for network 192.168.10.0 / 255.255.255.0.
branchRouter(dhcp-config)#default-router 192.168.10.1
branchRouter(dhcp-config)#dns-server 192.168.10.1
branchRouter(dhcp-config)#do wr
branchRouter(dhcp-config)#exit
a dhcp pool is created now i have to run a dhcp command on a pc to contact a dhcp server and gets its ip address
Subscribe to my newsletter
Read articles from Gurkeet Singh directly inside your inbox. Subscribe to the newsletter, and don't miss out.
Written by
